Install instructions
Prefer video tutorials instead of text? Click here!
  1. 1.
    Go to Files
  2. 2.
    Click Install on the topmost CurseForge version
  3. 3.
    Accept the prompt (if asked), download should start
Or with the launcher already open:
  1. 1.
    Select Minecraft from the grid or sidebar
  2. 2.
    Search "Fabulously Optimized"
  3. 3.
    Click Install

MultiMC

1.17 needs Java 16+, 1.18 needs Java 17+. Get Java
  1. 1.
    Go to Files
  2. 2.
    Click Download on the latest MultiMC version
    • Don't see the MultiMC version? Click the title of the CurseForge version you need and scroll down, you'll find the MultiMC variant there.
      • Alternatively, look for it in the sidebar, under "server packs".
    • If you don't see any mods inside the zip or only see one, you downloaded the wrong version.
  3. 3.
    Drag the ZIP-archive to MultiMC window

MultiMC (auto-update)

1.17 needs Java 16+, 1.18 needs Java 17+. Get Java
  1. 1.
    Go to readme, click "Alternative downloads"
  2. 2.
    Click the version number you need in the MultiMC (auto-update) section
  3. 3.
    Drag the ZIP-archive to MultiMC window
  4. 4.
    If you get asked to download a specific jar, it means I am not allowed to bundle it and you must add it manually:
    1. 1.
      Copy its url to your browser
    2. 2.
      Click Cancel Launch
    3. 3.
      Click Download on the mod
    4. 4.
      On MultiMC, right click on the instance -> View Mods
    5. 5.
      Drag the downloaded mod into the mod list
    6. 6.
      Click Launch
Please make sure your GDLauncher is up to date (v1.1.14 or later - see settings) before installing FO. Easiest way to do that is to redownload (no need to remove it first).
  1. 1.
    Click ➕ on bottom left corner
  2. 2.
    Select CurseForge tab
  3. 3.
    Search for "Fabulously Optimized"
  4. 4.
    Click Download Latest
  5. 5.
    Click ➡️ on the bottom right

Minecraft Launcher (vanilla)

For macOS or Linux you need Java to run the Fabric installer.
  1. 1.
    Download and install Fabric Loader version 0.14.8
    • Older versions of the modpack - 1.12.3 and 2.7.3 need Fabric Loader 0.13.3.
  2. 2.
    Open Minecraft Launcher, click Installations and then click 📂 on the Fabric installation
  3. 3.
    Go to Files on CurseForge
  4. 4.
    Click Download on the latest MultiMC version of the pack
    • Don't see the MultiMC version? Click the title of the CurseForge version you need and scroll down, you'll find the MultiMC variant there.
      • Alternatively, look for it in the sidebar, under "server packs".
    • If you don't see any mods inside the zip or only see one, you downloaded the wrong version.
  5. 5.
    Open the zip file, go to Fabulously Optimized x.x.x > .minecraft
  6. 6.
    Copy all folders from zip's .minecraft folder to your .minecraft folder; if asked - replace the files
  7. 7.
    If you want FO default settings as well, delete options.txt (your vanilla options will be reset)
  8. 8.
    Launch the installed Fabric profile
  9. 9.
    If you now see "Fabulously Optimized" in the right bottom corner, you're done!
A simple installer for vanilla launcher is coming soon!

Modrinth

There is indeed an official listing of FO on Modrinth. However, it is currently experimental and there is no official launcher yet, so no instructions or support are given.
Meanwhile you can ♡ Follow the project to get notified of updates 🙂

Other launchers

Technically you can install it in some other launchers that support CurseForge modpacks or in any launcher by following the vanilla instructions. However, I do not give support for them.

Servers

Any server is supported, no installation or changes are necessary. See server setup for more info.

Quilt

There have been questions regarding whether Fabulously Optimized can be installed with Quilt. The answer is: probably, while Fabric mods are still supported in it, but this modpack's maintainer does not provide support for that. (You can ask in Quilt's Discord, though.)
If there becomes a need, Fabulously Optimized will move to Quilt overall and then it will be fully supported. Read more on issue #257.