Links

Resource pack issues

Fabulously Optimized supports various OptiFine features, including resource pack extras. However, the implementation differs from mod to mod and some resource packs are accepted in OptiFine even if they are broken, so this page should help you fix some of those issues.
Before trying any of those things here, though, make sure you are using the latest version.

Broken paths

If you see this message while activating a resource pack:
Contains broken paths
This means the resource pack maker is using spaces or other non-standard characters in the file or folder names.
If this is the case, the modpack will warn you and allow overriding it, but note that various glitches may occur (miscolored or invisible blocks, lightning issues, broken textures...).
To fix that, please tell the resource pack maker to only use the following characters in file/folder names: a-z0-9._-.

Invisible blocks

This may occur when the pack is using broken paths and is trying to change the models of some blocks, like chests.

Enhanced Block Entities

Enhanced Block Entities is the mod that makes various blocks faster on latest versions of FO. Some optimizations may not be supported by your resource packs, so here's how to configure it:
  1. 1.
    Click Mods
  2. 2.
    Search for "Enhanced Block Entities", click the config button
    config
    ​
  3. 3.
    Disable any blocks that seem broken to you. Usually disabling Enhanced Chests is enough.
  4. 4.
    Click Done

FastChest and Better Beds

Some versions of FO include these mods instead.
Chests:
  1. 1.
    Click Mods
  2. 2.
    Search for "FastChest", click the config button
    ​
  3. 3.
    Disable the mod, click Done.
Beds:
  1. 1.
    Close the game
  2. 2.
    Remove or disable the Better Beds mod from your launcher.
  3. 3.
    Start the game and see if it is fixed.

Lighting problems

​
Random colors on the wall
If you are seeing problems with lighting, such as flickering light sources or lights of random colors, try disabling Colormatic.

Custom entity models

Or "mobs with a custom shape".
If you are just looking for Fresh Animations, try this version with the instructions below (discuss any issues here).
If your resource pack's entities are supported but are still not displayed correctly, you can try this:
  1. 1.
    Click Mods
  2. 2.
    Search for "Custom Entity Models", click the config button (top right, above Issues)
  3. 3.
    Set "Use model creation fix?" to No
  4. 4.
    Click Save & Quit and Done
  5. 5.
    In your world, hold down F3 (and Fn on laptops), press T
  6. 6.
    You'll see a short loading screen. After that, check if the models are displayed correctly.
  7. 7.
    If they still are not, set that setting back to Yes and disable your resource pack, wait for CEM to implement them.
    • Or if you want to continue using your resource pack without the models, disable the optifine setting in CEM to essentially disable the mod.